NRGship end of life for older operating systems due to UPS updates


Some things areĀ built to last forever, unfortunately computer hardware and software is not. IT departments regularly replace workstations as they grow slow over time, stop receiving operating system updates, or fall out of warranty.

If you have an older Mac you’ve probably noticed that you can’t use Safari with many websites. Banking websites require higher security and others like Google Maps utilize features in newer Safari releases.

Recently UPS has begun a process to update their servers for higher security standards. Starting in January 1, 2018, Macs running OS versions less than 10.9 or PC’s with Windows XP will no longer be able to connect to the UPS servers. FedEx performed similar server updates in late 2016. NRG currently recommends that users run OS X El Capitan (10.11) or Sierra (10.12) for best performance. If your Mac is not updatable then it would need to be replaced with newer hardware that can run a more recent OS release.

You can find more information regarding the security updates the UPS website.

Get more information on upgrading to OS X El Capitan (10.11) at apple.com.

  1. No comments yet.
(will not be published)