NRGship Pro for UPS is now compatible with macOS 10.13, High Sierra

NRG Software is excited to announce that NRGship Pro for UPS 2018 is now available for download. This version includes full compatability with macOS 10.13, High Sierra. Please see our support documentation for information on upgrading or watch the quick video below. macOS 10.11 or above is required to run NRGship Pro for UPS 2018.

  1. No comments yet.
(will not be published)

%d bloggers like this: