Using NRGship on Older Macs


The recent expiration of root certificates has caused some issues with older Macs running 10.10 Yosemite and 10.11 El Capitan. This is not an issue with NRGship, it is due to the fact that updates for these older operating systems have not been provided by Apple since 2018 so they cannot connect securely to modern day websites.

We highly recommend updating to 10.13 macOS High Sierra or above for any Mac released since 2010. You can find more infromation on supported hardware for macOS High Sierra on the Apple website.

If you have a 2009 vintage Mac, you could also update to 10.12 macOS Sierra.

We do realize that updates may not be possible on older hardware. ¬†With a few simple steps you can edit your security settings to allow access to the nrgsoft website on these older computers as a possible workaround. In the video below we’ll show you how you can go into Safari and enable trust settings.

  1. No comments yet.
(will not be published)



%d bloggers like this: